collapse

Welcome!



Welcome to Robot Rebels, an online robot maker community.

Register today to post your projects, ask questions, share knowledge and meet like-minded people from around the world.


The RobotRebel.org Community

Author Topic: MKS Gen L 1.0  (Read 120038 times)

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #45 on: May 18, 2019, 11:16:21 AM »
"do i now compile and upload to the board or save all the files (6) to sd card ??"

upload marlin to the board with the changes, there no files to save to SD, forget everything to do with mks TFT

if the screen still blank or BEEPS ... we'll talk about swapping leads around but fingers crossed it want be a problem 
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #46 on: May 18, 2019, 02:01:41 PM »
ok i compiled it and found an error was me i didnt add a space after the baudrate, so now compiled then hit upload and get this
Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

Sketch uses 83864 bytes (33%) of program storage space. Maximum is 253952 bytes.
Global variables use 2763 bytes (33%) of dynamic memory, leaving 5429 bytes for local variables. Maximum is 8192 bytes.
avrdude: ser_open(): can't set com-state for "\\.\COM9"
avrdude: ser_drain(): read error: The handle is invalid.

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: The handle is invalid.

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: The handle is invalid.

avrdude: stk500v2_ReceiveMessage(): timeout
avrdude: stk500v2_getsync(): timeout communicating with programmer
the selected serial port avrdude: stk500v2_getsync(): timeout communicating with programmer
 does not exist or your board is not connected

This report would have more information with
"Show verbose output during compilation"
option enabled in File -> Preferences.
« Last Edit: May 18, 2019, 02:18:20 PM by Bappi »
lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #47 on: May 18, 2019, 04:10:22 PM »
you looked in Tools in the edi see if you com port  matches...  failing that go back and comment  out the screen, see if it uploads, recall reading about a bug with marlin2 on the controller screen somewhere if that fails  then re start the computer! gotta say I dont have a lot of experience with Marlin2.
    we could be in the dark art of re-flashing the mega bootloader...
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #48 on: May 18, 2019, 04:25:37 PM »
ok will do but if marlin 1.1.x is easier i also have that  :))
lifes a bitch then u marry one.....

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #49 on: May 18, 2019, 04:38:59 PM »
ok tried it both ways screen in and removed both fail so will try 1.1
lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #50 on: May 19, 2019, 08:50:41 AM »
"ok tried it both ways screen in and removed both fail so will try 1.1"
 how you getting on with marlin
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #51 on: May 19, 2019, 04:04:47 PM »
no joy on both versions on marlin 1.1.x i got loads of error messages
lifes a bitch then u marry one.....

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #52 on: May 19, 2019, 07:16:21 PM »
i get these errors in red when compiling with marlin 1.1.x on arduino 1.8.9 com 9 with arduino/genuino mega or mega 2560 programmer arduinoisp

C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::codebits'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
c:/program files (x86)/arduino/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: Disabling relaxation: it will not work with multiple definitions
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::command_ptr'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::param'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::reset()'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::string_arg'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::command_letter'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::codenum'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::parse(char*)'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::unknown_command_error()'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `parser'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\parser.cpp.o (symbol from plugin): In function `GCodeParser::codebits':
(.text+0x0): multiple definition of `GCodeParser::value_ptr'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\gcode.cpp.o (symbol from plugin):(.text+0x0): first defined here
HardwareSerial0.cpp.o (symbol from plugin): In function `Serial':
(.text+0x0): multiple definition of `__vector_25'
C:\Users\Bappi\AppData\Local\Temp\arduino_build_585814\sketch\MarlinSerial.cpp.o (symbol from plugin):(.text+0x0): first defined here
collect2.exe: error: ld returned 1 exit status
exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.

lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #53 on: May 20, 2019, 03:31:49 AM »
post a copy of your config.h and config.adv gonna see if i can replicate those errors with my edi... while you waiting just comment out everything to do with the BLtouch probe.... though my gut feeling is you gonna need to flash the bootloader for the mega.. you got and uno laying around or another arduino... and some jumper leads
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #54 on: May 20, 2019, 02:53:00 PM »
Ok i decided to delete all versions of marlin and arduino from my hard drive and start from the beginning. I downloaded arduino 1.8.9-windows  and fresh installed, i then downloaded marlin 1.1.x bugfix and opened this in arduino edited line 1671 reprap discount full graphic smart controller
i then compiled with arduino/genuino mega or mega 2560 on com port 9. i dont know if it makes any difference but i set programmer as arv isp.
It compiled correctly but when i hit upload it failed
results below
Arduino: 1.8.9 (Windows 10), Board: "Arduino/Genuino Mega or Mega 2560, ATmega2560 (Mega 2560)"

C:\Users\Bappi\AppData\Local\Temp\arduino_build_239645\sketch\planner.cpp:2697:1: internal compiler error: Segmentation fault

 }

 ^
Please submit a full bug report,
with preprocessed source if appropriate.
See <http://gcc.gnu.org/bugs.html> for instructions.
lto-wrapper.exe: fatal error: C:\Program Files (x86)\Arduino\hardware\tools\avr/bin/avr-gcc returned 1 exit status
compilation terminated.
c:/program files (x86)/arduino/hardware/tools/avr/bin/../lib/gcc/avr/5.4.0/../../../../avr/bin/ld.exe: error: lto-wrapper failed
collect2.exe: error: ld returned 1 exit status
Using library U8glib at version 1.19.1 in folder: C:\Users\Bappi\Documents\Arduino\libraries\U8glib
exit status 1
Error compiling for board Arduino/Genuino Mega or Mega 2560.
lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #55 on: May 20, 2019, 03:16:02 PM »
"i set programmer as arv isp."

set that to AVRISP mkII,,,I think you use arv isp if you where using a boot loader or 3rd party device to upload to a raw chip or something, you want need that.

then comment out the the reprap screen  see if it uploads i just tested  A RAMPS it uploaded fine with a fresh win10 and latest arduino EDI :o yea RAMPS thinks it a gen l now!
« Last Edit: May 20, 2019, 03:34:14 PM by jinx »
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #56 on: May 20, 2019, 07:11:31 PM »
ok  doing what you just asked COMPILED
Sketch uses 54526 bytes (21%) of program storage space. Maximum is 253952 bytes.
Global variables use 2513 bytes (30%) of dynamic memory, leaving 5679 bytes for local variables. Maximum is 8192 bytes.

when uploading
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files (x86)\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM9
         Using Programmer              : wiring
         Overriding Baud Rate          : 115200
avrdude: ser_open(): can't set com-state for "\\.\COM9"
avrdude: ser_drain(): read error: The handle is invalid.


avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: The handle is invalid.


avrdude: stk500v2_ReceiveMessage(): timeout
the selected serial port avrdude: stk500v2_ReceiveMessage(): timeout
 does not exist or your board is not connected
avrdude: ser_send(): write error: sorry no info avail
avrdude: stk500_send(): failed to send command to serial port
avrdude: ser_recv(): read error: The handle is invalid.
lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #57 on: May 21, 2019, 02:28:17 AM »
 you got these USB driver https://www.ftdichip.com/Drivers/VCP.htm
this for the mega clones
 http://www.wch.cn/download/CH341SER_EXE.html

 grab both just in case! if it still fails after the driver installed have a read of this using an uno as a boot loader  http://www.robotrebels.org/index.php?topic=601.msg2869#msg2869

think my next step would be get another gen l and upload marlin avoid marlin 2 for now,,, grab an uno and follow the bootloader link above  then you have a spare for your second printer  ^-^
« Last Edit: May 21, 2019, 02:54:29 AM by jinx »
I build bots

Bappi

  • Member
  • ****
  • Posts: 13
Re: MKS Gen L 1.0
« Reply #58 on: May 21, 2019, 03:34:54 AM »
downloaded both drivers installed the ch341ser.exe and

avrdude: 54526 bytes of flash written
avrdude: verifying flash memory against C:\Users\Bappi\AppData\Local\Temp\arduino_build_697288/Marlin.ino.hex:
avrdude: load data flash data from input file C:\Users\Bappi\AppData\Local\Temp\arduino_build_697288/Marlin.ino.hex:
avrdude: input file C:\Users\Bappi\AppData\Local\Temp\arduino_build_697288/Marlin.ino.hex contains 54526 bytes
avrdude: reading on-chip flash data:

Reading | ################################################## | 100% 6.28s

avrdude: verifying ...
avrdude: 54526 bytes of flash verified

avrdude done.  Thank you.

but and theres always a but i have a blank screen
lifes a bitch then u marry one.....

jinx

  • calling from free Europe
  • Moderator
  • Sr. Member
  • *****
  • Posts: 469
Re: MKS Gen L 1.0
« Reply #59 on: May 21, 2019, 05:09:27 AM »
but and theres always a but i have a blank screen"

sure you enabled it? does it beep? once confirmed its enabled in firmware and still blank >:D you gonna need to switch leads around  ext1 goes to ext2 and 2 goes to 1,  you gonna need to rotate the leads 180 and cut a notch in the controller headers to fit leads, just like this http://www.robotrebels.org/index.php?topic=838.msg3918#msg3918
BUT before that just confirm firmware...
« Last Edit: May 21, 2019, 05:14:20 AM by jinx »
I build bots

 

* Search


* Recent Topics

Coding a Nano i2c Slave by AmandaG
[June 11, 2019, 02:48:03 PM]


repetierHost 2.1.6 not working? by MEgg
[June 09, 2019, 03:11:34 PM]


Servo Calibrator by Bajdi
[May 24, 2019, 04:01:10 AM]


MKS Gen L 1.0 by Bappi
[May 21, 2019, 07:22:54 PM]


ESP32 "Life is Life" 64x32 flexible P4 RGB LED by jinx
[May 18, 2019, 11:19:44 AM]


Warco HV-4" Rotary Table by jinx
[May 08, 2019, 03:12:58 PM]


Warco WM14 milling machine by jinx
[April 28, 2019, 09:41:40 AM]


MKS GEN L Servo Issue by Reywas
[April 22, 2019, 09:10:08 PM]


Meowth Abandoned by Nemesis
[April 11, 2019, 11:08:00 AM]


Bench Power: Help a rebel out by jinx
[April 03, 2019, 04:20:10 AM]


Just a short intro... by MEgg
[March 18, 2019, 05:49:28 PM]


Yes I am alive! by jinx
[March 10, 2019, 04:38:53 AM]


CZ-1 2.0: problems, calibration and printing, part2 by MEgg
[February 26, 2019, 03:35:15 PM]


Hi, Mushroom glue here. by nschreiber0813
[February 25, 2019, 02:09:13 PM]


Arduino IK by BaldwinK
[February 25, 2019, 05:54:44 AM]

* Recent Posts

Re: Coding a Nano i2c Slave by AmandaG
[June 11, 2019, 02:48:03 PM]


repetierHost 2.1.6 not working? by MEgg
[June 09, 2019, 03:11:34 PM]


Re: Servo Calibrator by Bajdi
[May 24, 2019, 04:01:10 AM]


Re: Servo Calibrator by jinx
[May 22, 2019, 02:28:13 AM]


Re: MKS Gen L 1.0 by Bappi
[May 21, 2019, 07:22:54 PM]


Re: MKS Gen L 1.0 by jinx
[May 21, 2019, 03:27:08 PM]


Re: MKS Gen L 1.0 by Bappi
[May 21, 2019, 03:11:45 PM]


Servo Calibrator by BaldwinK
[May 21, 2019, 10:20:42 AM]


Re: MKS Gen L 1.0 by jinx
[May 21, 2019, 05:09:27 AM]


Re: MKS Gen L 1.0 by Bappi
[May 21, 2019, 03:34:54 AM]


Re: MKS Gen L 1.0 by jinx
[May 21, 2019, 02:28:17 AM]


Re: MKS Gen L 1.0 by Bappi
[May 20, 2019, 07:11:31 PM]


Re: MKS Gen L 1.0 by jinx
[May 20, 2019, 03:16:02 PM]


Re: MKS Gen L 1.0 by Bappi
[May 20, 2019, 02:53:00 PM]


Re: MKS Gen L 1.0 by jinx
[May 20, 2019, 03:31:49 AM]